Reactor Dependency Convergence

Légende :
[Error] Au moins un projet a une dépendance de version différente.

Statistiques :
Nombre de sous-projets : 25
Nombre de dépendances (NOD) : 99
Nombre d'artefacts uniques (NOA) : 101
Number of version-conflicting artifacts (NOC): 2
Nombre d'artefacts SNAPSHOT (NOS) : 0
Convergence (NOD/NOA) : [Error] 98 %
Prêt pour la release (100% de convergence et aucun SNAPSHOT) : [Error] Erreur
Vous n'avez pas la convergence à 100%.

Dépendances utilisées dans les sous-projets

org.apache.maven:maven-artifact

[Error]
3.0
  1. org.nuiton.jaxx:jaxx-maven-plugin:maven-plugin:3.0-alpha-3
    \- org.apache.maven.plugin-tools:maven-plugin-annotations:jar:3.5:provided
       \- (org.apache.maven:maven-artifact:jar:3.0:provided - omitted for conflict with 3.3.9)

3.3.9
  1. org.nuiton.jaxx:jaxx-maven-plugin:maven-plugin:3.0-alpha-3
    +- org.apache.maven:maven-plugin-api:jar:3.3.9:compile
    |  \- org.apache.maven:maven-artifact:jar:3.3.9:compile
    +- org.apache.maven:maven-core:jar:3.3.9:provided
    |  +- (org.apache.maven:maven-artifact:jar:3.3.9:provided - omitted for duplicate)
    |  \- org.apache.maven:maven-model-builder:jar:3.3.9:provided
    |     \- (org.apache.maven:maven-artifact:jar:3.3.9:provided - omitted for duplicate)
    \- org.apache.maven:maven-compat:jar:3.3.9:provided
       \- (org.apache.maven:maven-artifact:jar:3.3.9:provided - omitted for duplicate)

org.codehaus.plexus:plexus-component-annotations

[Error]
1.5.5
  1. org.nuiton.jaxx:jaxx-maven-plugin:maven-plugin:3.0-alpha-3
    \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.3.3:test
       \- (org.codehaus.plexus:plexus-component-annotations:jar:1.5.5:test - omitted for conflict with 1.6)

1.6
  1. org.nuiton.jaxx:jaxx-maven-plugin:maven-plugin:3.0-alpha-3
    +- org.apache.maven:maven-core:jar:3.3.9:provided
    |  +- org.apache.maven:maven-settings-builder:jar:3.3.9:provided
    |  |  \- (org.codehaus.plexus:plexus-component-annotations:jar:1.6:provided - omitted for conflict with 1.5.5)
    |  +- org.apache.maven:maven-model-builder:jar:3.3.9:provided
    |  |  \- (org.codehaus.plexus:plexus-component-annotations:jar:1.6:provided - omitted for conflict with 1.5.5)
    |  \- org.codehaus.plexus:plexus-component-annotations:jar:1.6:provided
    +- org.apache.maven:maven-compat:jar:3.3.9:provided
    |  \- (org.codehaus.plexus:plexus-component-annotations:jar:1.6:provided - omitted for duplicate)
    \- org.apache.maven:maven-aether-provider:jar:3.3.9:provided
       \- (org.codehaus.plexus:plexus-component-annotations:jar:1.6:provided - omitted for duplicate)